Go to Bottom

Compact and Repair Database

In this Topic: Show


The procedures covered in this topic are for use with Microsoft Access databases only.

If data or objects are deleted from an MS Access database, or project, the file can become fragmented and use disk space inefficiently. Using the Compact and Repair feature of Microsoft Access on a regular basis will also keep an Access database or project from reaching the 2GB size limit. Once a file reaches that size it will cease to function.

The compact process makes a copy of the Access file and rearranges how the file is stored on your disk.

Compacting an Access database that is in the format of a lower-level version of Access will not cause it to be converted to the format of the current version of Access that is installed.

Compact and Repair Program File

  1. Close the Order Manager on the affected workstation.

  2. Manually make a backup copy of the program file before proceeding.

  3. Press and hold down the [Shift] key while double-clicking the Order Manager shortcut icon on the desktop ,until the MS Access database window opens.

  4. Go to Tools> Database Utilities> Compact and Repair.

  5. When the compaction process is complete, close out of the MS Access window and re-open the Order Manager normally.

Manually Compact and Repair Store Data File

  1. Close ALL instances of the Order Manager.

  2. Close any shipping software that may be accessing the data file.

  3. Re-open one instance of Order Manager.

  4. Backup the store data file by clicking on the Backup Data File button on the Quick Clicks menu or by going to the Maintenance Menu>Maintenance Tab>Backup Data File>Go.

The program will name the backup copy of the data file in the form, YourStoreName BACKUP YYYY-MMM-DD.mdb. is the name of the current Order Manager store and is the date that the backup was created. The program will also store the creation date and time, of the most recent backup, as well as the name of the workstation from which it was created and the path to the location of the backup file. It can be viewed by using the Ctrl+Shift+C key combination at the Main Menu.

  1. Access the data file by one of two ways:

    1. Use the keyboard shortcut combination Ctrl+Shift+D without closing the Order Manager, or

    2. Close the Order Manager again.

      1. Open Windows Explorer and navigate to the location of your store file. Press Ctrl+Shift+C at the Main Menu of Order Manager to determine the location of your data file.

      2. Double-click on it to open the file.

  2. From the Access menu bar, go to Tools> Database Utilities> Compact and Repair.

If you encounter an error during the compact process and need to restore the data file from the backup, copy the most recent backup file and paste it into the folder where the data file normally resides. Rename the failing production data file (for example, mystore.mdb to mystore_bad.mdb) and then rename the backup copy to the production name (mystore.mdb). Re-open the Order Manager.

  1. Close the Microsoft Access database window and re-open the Stone Edge Order Manager by clicking on the desktop icon.


Related Topics


Created: 1/26/11

Go to Top